Issues creating connection

May 23, 2012 at 6:09 PM

When I try to create a connection (OnPremise) after filling information I try to get organizations. I keep getting the following error

"Error while retrieving organizations : Metadata contains a ref that cannot be resolved

http://myserver:8080/xrmservces/2011/discovery.svc?wsdl'.

the remote server returned an erorr: 401 Unauthorized.

 

I have tried without a port assigned and get an error as well.

Could not load file or assembly 'Microsoft.IdentityModel, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35' or one of its dependencies, The system cannot find the file specified. 

 

Please help.

 

Thank you!

Shaun

Coordinator
May 23, 2012 at 6:12 PM

Hi Shaun,

You must install Windows Identity Foundation on your computer to make my tools work.

So, it requires Windows Vista minimum...

Link to download : http://www.microsoft.com/en-us/download/details.aspx?id=17331 

May 23, 2012 at 7:14 PM

I had that installed on the box and just to make sure I acutally removed it and reinstalled.  The server is 2008R2 if that matters but even after uninstalling and reinstalling on the server it still continues to give errors.  Any suggestions?

Coordinator
May 23, 2012 at 8:23 PM

Could you provide values you are using to set the connection?

Then paste here the url you used to validate you can access to the web application

May 24, 2012 at 1:08 PM

I was trying to connect with the following

I tried both windows integrated authentication as well as custom using several different admin accounts as well as service accounts.

for Server name I tried with the server name of the server as well as just IP and FQDN

for port I used blank and tried a few port numbers we have used.

 

The url to verify access to the app is just http:// followed by the FQDN.  I dont know if it matters or not but we also have a SP site on the box as well for this.  Which is the same address but on a specific port.

 

Thanks for all your help!

Coordinator
May 24, 2012 at 1:13 PM

Did you change port number during CRM web application lifetime?

If you did, without updating the MSCRM_CONFIG database DeploymentProperties table, then my tool can't work...

May 24, 2012 at 2:40 PM
Edited May 25, 2012 at 2:25 PM

No we didnt change the port number for CRM.  It was installed as default

 

Any other suggestions??